diff Makefile.am @ 8:0c98b46eaf73 v2.0

*: update API to 2.0, big changes all APIs now use pointers to an EDL object. it is up to the user to make sure that the pointer is valid. additionally, many things have been separated into new files to make it easier to digest
author Paper <paper@paper.us.eu.org>
date Sun, 03 Mar 2024 17:56:58 -0500
parents fee08fa622e1
children
line wrap: on
line diff
--- a/Makefile.am	Mon Jan 15 06:42:30 2024 -0500
+++ b/Makefile.am	Sun Mar 03 17:56:58 2024 -0500
@@ -1,6 +1,17 @@
 lib_LTLIBRARIES = libedl.la
-libedl_la_SOURCES = src/edl.c src/str.c
+
+noinst_HEADERS =	\
+	include/datatypes.h	\
+	include/str.h	\
+	include/util.h
+
 include_HEADERS = include/edl.h
 
+libedl_la_SOURCES = \
+	src/edl.c \
+	src/str.c \
+	src/datatypes.c \
+	src/util.c
+
 AM_CPPFLAGS = -I$(srcdir)/include
 ACLOCAL_AMFLAGS = -I m4