diff configure.ac @ 2:d00bc412900e

*: fix up lots of stuff and make the thing actually usable
author Paper <mrpapersonic@gmail.com>
date Sun, 24 Dec 2023 20:01:30 -0500
parents
children bd99b6549eb4
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/configure.ac	Sun Dec 24 20:01:30 2023 -0500
@@ -0,0 +1,18 @@
+AC_INIT([libedl], [1.0])
+
+AC_CONFIG_SRCDIR([src/main.c])
+AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_MACRO_DIRS([m4])
+
+AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects])
+
+# Check for a C compiler
+AC_PROG_CC
+
+# Need this because libtool is weird
+AM_PROG_AR
+
+LT_INIT
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT