diff configure.ac @ 241:06d6c351925c

*: reorganize resources, +docs, build translations with autotools
author Paper <paper@paper.us.eu.org>
date Mon, 22 Jan 2024 16:36:19 -0500
parents 6ffe42286978
children 6b2441c776dd
line wrap: on
line diff
--- a/configure.ac	Fri Jan 19 13:47:56 2024 -0500
+++ b/configure.ac	Mon Jan 22 16:36:19 2024 -0500
@@ -18,21 +18,11 @@
 AM_PROG_AR
 LT_INIT
 
-have_qt=no
 # Qt?
 AX_HAVE_QT
 
 if test "x$have_qt" = "xno"; then
-	PKG_CHECK_MODULES([QT], [Qt6Widgets >= 6.0.0], [have_qt=yes], [true])
-	# prioritize qt 5
-	PKG_CHECK_MODULES([QT], [Qt5Widgets >= 5.15.0], [have_qt=yes], [true])
-
-	if test "x$have_qt" = "xno"; then
-		AC_MSG_ERROR([*** Qt not found.])
-	fi
-
-	QT_CXXFLAGS=$QT_CFLAGS
-	AC_SUBST([QT_CXXFLAGS])
+	AC_MSG_ERROR([*** Qt not found.])
 fi
 
 # need this for moc