diff dep/animone/configure.ac @ 270:0718f538c5f9

dep/animone: filter open files by access mode
author Paper <paper@paper.us.eu.org>
date Fri, 12 Apr 2024 19:13:50 -0400
parents 1a6a5d3a94cd
children a4257370de16
line wrap: on
line diff
--- a/dep/animone/configure.ac	Fri Apr 12 05:23:45 2024 -0400
+++ b/dep/animone/configure.ac	Fri Apr 12 19:13:50 2024 -0400
@@ -42,18 +42,15 @@
 		;;
 	*)
 		dnl BSDs
-		build_bsd=yes
-		AC_DEFINE([BSD])
 		AC_CHECK_LIB([util], [kinfo_getfile], [build_libutil=yes], [build_libutil=no])
-
-		dnl if we have this function it means kvm_openfiles likely also supports NULL values,
-		dnl i.e., loading the currently running kernel
 		AC_CHECK_LIB([kvm], [kvm_getfiles], [build_kvm=yes], [build_kvm=no])
 
 		if test "x$build_kvm" = "xyes"; then
 			AC_DEFINE([LIBKVM])
+			AC_DEFINE([BSD])
 		elif test "x$build_libutil" = "xyes"; then
 			AC_DEFINE([LIBUTIL])
+			AC_DEFINE([BSD])
 		fi
 		;;
 esac