diff dep/animone/Makefile.am @ 266:1a6a5d3a94cd

dep/animone: make bsd.cc and x11.cc actually work apparently I broke these, and even now the x11 code *still* doesn't want to work correctly (at least on FreeBSD). half of the PID response codes are just 0 or the PID for the X server itself... wtf? maybe dwm just doesn't support the XRes extension, or I'm just stupid. i don't know.
author Paper <paper@paper.us.eu.org>
date Thu, 11 Apr 2024 22:05:41 -0400
parents 862d0d8619f6
children ab7ff259b4ca
line wrap: on
line diff
--- a/dep/animone/Makefile.am	Thu Apr 11 10:22:05 2024 -0400
+++ b/dep/animone/Makefile.am	Thu Apr 11 22:05:41 2024 -0400
@@ -10,7 +10,7 @@
 	include/animone/types.h
 
 noinst_HEADERS = \
-	include/animone/fd/kvm.h \
+	include/animone/fd/bsd.h \
 	include/animone/fd/proc.h \
 	include/animone/fd/win32.h \
 	include/animone/fd/xnu.h \
@@ -39,14 +39,23 @@
 files_linux = src/fd/proc.cc
 endif
 
-# these should be in standard locations anyway
+# BSD stuff
+if BUILD_BSD
+
+files_bsd = src/fd/bsd.cc
+
+endif
+
 if BUILD_LIBUTIL
+
 libs_libutil = -lutil
+
 endif
 
 if BUILD_LIBKVM
-files_libkvm = src/fd/kvm.cc
+
 libs_libkvm = -lkvm
+
 endif
 
 if BUILD_XCB
@@ -68,8 +77,7 @@
 	$(files_win) \
 	$(files_osx) \
 	$(files_linux) \
-	$(files_libutil) \
-	$(files_libkvm) \
+	$(files_bsd) \
 	$(files_x11) \
 	$(files_wayland)