diff dep/animone/configure.ac @ 266:1a6a5d3a94cd

dep/animone: make bsd.cc and x11.cc actually work apparently I broke these, and even now the x11 code *still* doesn't want to work correctly (at least on FreeBSD). half of the PID response codes are just 0 or the PID for the X server itself... wtf? maybe dwm just doesn't support the XRes extension, or I'm just stupid. i don't know.
author Paper <paper@paper.us.eu.org>
date Thu, 11 Apr 2024 22:05:41 -0400
parents 862d0d8619f6
children 0718f538c5f9
line wrap: on
line diff
--- a/dep/animone/configure.ac	Thu Apr 11 10:22:05 2024 -0400
+++ b/dep/animone/configure.ac	Thu Apr 11 22:05:41 2024 -0400
@@ -19,6 +19,7 @@
 build_linux=no
 build_libutil=no
 build_kvm=no
+build_bsd=no
 
 build_x11=no
 
@@ -40,21 +41,24 @@
 		AC_DEFINE([LINUX])
 		;;
 	*)
-		# FreeBSD
+		dnl BSDs
+		build_bsd=yes
+		AC_DEFINE([BSD])
 		AC_CHECK_LIB([util], [kinfo_getfile], [build_libutil=yes], [build_libutil=no])
-		if test "x$build_libutil" = "xyes"; then
+
+		dnl if we have this function it means kvm_openfiles likely also supports NULL values,
+		dnl i.e., loading the currently running kernel
+		AC_CHECK_LIB([kvm], [kvm_getfiles], [build_kvm=yes], [build_kvm=no])
+
+		if test "x$build_kvm" = "xyes"; then
+			AC_DEFINE([LIBKVM])
+		elif test "x$build_libutil" = "xyes"; then
 			AC_DEFINE([LIBUTIL])
-		else
-			# OpenBSD
-			AC_CHECK_LIB([kvm], [kvm_getfiles], [build_kvm=yes], [build_kvm=no])
-			if test "x$build_kvm" = "xyes"; then
-				AC_DEFINE([LIBKVM])
-			fi
 		fi
 		;;
 esac
 
-if test "x$build_osx" = "xno" && test "x$build_windows" = "xno"; then
+if test "x$build_osx" != "xyes" && test "x$build_windows" != "xyes"; then
 	PKG_CHECK_MODULES(XCB, [xcb xcb-res], [build_x11=yes], [build_x11=no])
 	if test "x$build_x11" = "xyes"; then
 		AC_DEFINE([X11])
@@ -68,6 +72,7 @@
 AM_CONDITIONAL([BUILD_LINUX], [test "x$build_linux" = "xyes"])
 AM_CONDITIONAL([BUILD_LIBUTIL], [test "x$build_libutil" = "xyes"])
 AM_CONDITIONAL([BUILD_LIBKVM], [test "x$build_kvm" = "xyes"])
+AM_CONDITIONAL([BUILD_BSD], [test "x$build_bsd" = "xyes"])
 
 AM_CONDITIONAL([BUILD_XCB], [test "x$build_x11" = "xyes"])