diff Makefile.am @ 247:1ae4d8b28a5c

autotools/windres: use AC_PROG_SED for sed sed is actually surprisingly unportable. on mingw this shouldn't be a problem, but alas, we should use it anyway
author Paper <mrpapersonic@gmail.com>
date Wed, 24 Jan 2024 20:15:35 -0500
parents 4d461ef7d424
children 6b2441c776dd
line wrap: on
line diff
--- a/Makefile.am	Fri Jan 19 00:24:02 2024 -0500
+++ b/Makefile.am	Wed Jan 24 20:15:35 2024 -0500
@@ -69,7 +69,7 @@
 
 if BUILD_WINDRES
 # Untested...
-wrcflags_version = -DWRC_VERSION=0,`echo '$(PACKAGE_VERSION)' | sed 's/(\d+)\.(\d+)\.(\d+)/\1,\2,\3/'`
+wrcflags_version = -DWRC_VERSION=0,`echo '$(PACKAGE_VERSION)' | @SED@ 's/(\d+)\.(\d+)\.(\d+)/\1,\2,\3/'`
 
 WRCFLAGS = --use-temp-file -I. -I$(srcdir) $(wrcflags_version)
 .rc.$(OBJEXT):