diff configure.ac @ 247:1ae4d8b28a5c

autotools/windres: use AC_PROG_SED for sed sed is actually surprisingly unportable. on mingw this shouldn't be a problem, but alas, we should use it anyway
author Paper <mrpapersonic@gmail.com>
date Wed, 24 Jan 2024 20:15:35 -0500
parents 4d461ef7d424
children 6b2441c776dd
line wrap: on
line diff
--- a/configure.ac	Fri Jan 19 00:24:02 2024 -0500
+++ b/configure.ac	Wed Jan 24 20:15:35 2024 -0500
@@ -42,6 +42,8 @@
 		build_windows=yes
 		AC_CHECK_TOOL([WINDRES], [windres])
 		AC_SUBST(WINDRES)
+		AC_PROG_SED # We need sed for version numbers in windres
+		AC_SUBST(SED)
 		AC_DEFINE(WIN32)
 		;;
 	darwin*)