diff dep/anitomy/CMakeLists.txt @ 343:1faa72660932

*: transfer back to cmake from autotools autotools just made lots of things more complicated than they should have and many things broke (i.e. translations)
author Paper <paper@paper.us.eu.org>
date Thu, 20 Jun 2024 05:56:06 -0400
parents
children a0aa8c8c4307
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dep/anitomy/CMakeLists.txt	Thu Jun 20 05:56:06 2024 -0400
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 3.9)
+project(anitomy)
+add_library(anitomy SHARED
+	anitomy/anitomy.cpp
+	anitomy/element.cpp
+	anitomy/keyword.cpp
+	anitomy/parser.cpp
+	anitomy/parser_helper.cpp
+	anitomy/parser_number.cpp
+	anitomy/string.cpp
+	anitomy/token.cpp
+	anitomy/tokenizer.cpp
+)
+set_target_properties(anitomy PROPERTIES
+    PUBLIC_HEADER anitomy/anitomy.h CXX_STANDARD 17)
+target_include_directories(anitomy PRIVATE src)