diff CMakeLists.txt @ 138:28842a8d0c6b

dep/animia: huge refactor (again...) but this time, it actually compiles! and it WORKS! (on win32... not sure about other platforms...) configuring players is still not supported: at some point I'll prune something up...
author Paper <mrpapersonic@gmail.com>
date Sun, 12 Nov 2023 04:53:19 -0500
parents 859d2a957940
children 6fdf0632c003
line wrap: on
line diff
--- a/CMakeLists.txt	Fri Nov 10 13:52:47 2023 -0500
+++ b/CMakeLists.txt	Sun Nov 12 04:53:19 2023 -0500
@@ -110,6 +110,7 @@
 	# Qt resources
 	rc/icons.qrc
 	rc/dark.qrc
+	rc/player_data.qrc
 )
 
 set(INCLUDE
@@ -204,3 +205,7 @@
 	target_compile_definitions(minori PUBLIC WIN32)
 endif()
 target_link_libraries(minori ${LIBRARIES})
+
+if(WIN32)
+	install(FILES $<TARGET_RUNTIME_DLLS:minori> TYPE BIN)
+endif()