diff Makefile.am @ 318:3b355fa948c7

config: use TOML instead of INI unfortunately, INI is not enough, and causes some paths including semicolons to break with our current storage of the library folders. so, I decided to switch to TOML which does support real arrays...
author Paper <paper@paper.us.eu.org>
date Wed, 12 Jun 2024 05:25:41 -0400
parents b1f4d1867ab1
children 10096c5489e3
line wrap: on
line diff
--- a/Makefile.am	Wed Jun 12 04:07:10 2024 -0400
+++ b/Makefile.am	Wed Jun 12 05:25:41 2024 -0400
@@ -162,7 +162,6 @@
 	include/core/config.h		\
 	include/core/date.h		\
 	include/core/filesystem.h			\
-	include/core/ini.h		\
 	include/core/json.h			\
 	include/core/strings.h			\
 	include/core/time.h			\
@@ -178,7 +177,30 @@
 	include/track/media.h			\
 	dep/json/json.hpp	\
 	dep/json/json_fwd.hpp	\
-	dep/mini/ini.h	\
+	dep/toml11/toml.hpp \
+	dep/toml11/toml/color.hpp \
+	dep/toml11/toml/combinator.hpp \
+	dep/toml11/toml/comments.hpp \
+	dep/toml11/toml/datetime.hpp \
+	dep/toml11/toml/exception.hpp \
+	dep/toml11/toml/from.hpp \
+	dep/toml11/toml/get.hpp \
+	dep/toml11/toml/into.hpp \
+	dep/toml11/toml/lexer.hpp \
+	dep/toml11/toml/literal.hpp \
+	dep/toml11/toml/macros.hpp \
+	dep/toml11/toml/parser.hpp \
+	dep/toml11/toml/region.hpp \
+	dep/toml11/toml/result.hpp \
+	dep/toml11/toml/serializer.hpp \
+	dep/toml11/toml/source_location.hpp \
+	dep/toml11/toml/storage.hpp \
+	dep/toml11/toml/string.hpp \
+	dep/toml11/toml/traits.hpp \
+	dep/toml11/toml/types.hpp \
+	dep/toml11/toml/utility.hpp \
+	dep/toml11/toml/value.hpp \
+	dep/toml11/toml/version.hpp \
 	dep/semver/semver.hpp	\
 	$(minori_qtheaders)
 
@@ -196,7 +218,6 @@
 	src/core/date.cc		\
 	src/core/filesystem.cc		\
 	src/core/http.cc		\
-	src/core/ini.cc			\
 	src/core/json.cc		\
 	src/core/session.cc     \
 	src/core/strings.cc		\