diff Makefile.am @ 329:4aeffed717ef

dep/fmt: add dependency
author Paper <paper@paper.us.eu.org>
date Mon, 17 Jun 2024 04:54:44 -0400
parents 10096c5489e3
children a7d4e5107531
line wrap: on
line diff
--- a/Makefile.am	Fri Jun 14 00:37:45 2024 -0400
+++ b/Makefile.am	Mon Jun 17 04:54:44 2024 -0400
@@ -17,7 +17,57 @@
 
 # Qt resources
 
+dep_json_include = \
+	dep/json/json.hpp \
+	dep/json/json_fwd.hpp
 
+dep_toml_include = \
+	dep/toml11/toml.hpp \
+	dep/toml11/toml/color.hpp \
+	dep/toml11/toml/combinator.hpp \
+	dep/toml11/toml/comments.hpp \
+	dep/toml11/toml/datetime.hpp \
+	dep/toml11/toml/exception.hpp \
+	dep/toml11/toml/from.hpp \
+	dep/toml11/toml/get.hpp \
+	dep/toml11/toml/into.hpp \
+	dep/toml11/toml/lexer.hpp \
+	dep/toml11/toml/literal.hpp \
+	dep/toml11/toml/macros.hpp \
+	dep/toml11/toml/parser.hpp \
+	dep/toml11/toml/region.hpp \
+	dep/toml11/toml/result.hpp \
+	dep/toml11/toml/serializer.hpp \
+	dep/toml11/toml/source_location.hpp \
+	dep/toml11/toml/storage.hpp \
+	dep/toml11/toml/string.hpp \
+	dep/toml11/toml/traits.hpp \
+	dep/toml11/toml/types.hpp \
+	dep/toml11/toml/utility.hpp \
+	dep/toml11/toml/value.hpp \
+	dep/toml11/toml/version.hpp
+
+dep_semver_include = \
+	dep/semver/semver.hpp
+
+dep_fmt_include = \
+	dep/fmt/include/fmt/ostream.h \
+	dep/fmt/include/fmt/format-inl.h \
+	dep/fmt/include/fmt/ranges.h \
+	dep/fmt/include/fmt/xchar.h \
+	dep/fmt/include/fmt/core.h \
+	dep/fmt/include/fmt/chrono.h \
+	dep/fmt/include/fmt/os.h \
+	dep/fmt/include/fmt/color.h \
+	dep/fmt/include/fmt/args.h \
+	dep/fmt/include/fmt/printf.h \
+	dep/fmt/include/fmt/compile.h \
+	dep/fmt/include/fmt/format.h \
+	dep/fmt/include/fmt/std.h
+
+dep_fmt_source = \
+	dep/fmt/src/format.cc \
+	dep/fmt/src/os.cc
 
 minori_qtrc = \
 	$(top_srcdir)/rc/icons/icons.qrc	\
@@ -174,33 +224,10 @@
 	include/sys/osx/permissions.h   \
 	include/sys/win32/dark_theme.h	\
 	include/track/media.h			\
-	dep/json/json.hpp	\
-	dep/json/json_fwd.hpp	\
-	dep/toml11/toml.hpp \
-	dep/toml11/toml/color.hpp \
-	dep/toml11/toml/combinator.hpp \
-	dep/toml11/toml/comments.hpp \
-	dep/toml11/toml/datetime.hpp \
-	dep/toml11/toml/exception.hpp \
-	dep/toml11/toml/from.hpp \
-	dep/toml11/toml/get.hpp \
-	dep/toml11/toml/into.hpp \
-	dep/toml11/toml/lexer.hpp \
-	dep/toml11/toml/literal.hpp \
-	dep/toml11/toml/macros.hpp \
-	dep/toml11/toml/parser.hpp \
-	dep/toml11/toml/region.hpp \
-	dep/toml11/toml/result.hpp \
-	dep/toml11/toml/serializer.hpp \
-	dep/toml11/toml/source_location.hpp \
-	dep/toml11/toml/storage.hpp \
-	dep/toml11/toml/string.hpp \
-	dep/toml11/toml/traits.hpp \
-	dep/toml11/toml/types.hpp \
-	dep/toml11/toml/utility.hpp \
-	dep/toml11/toml/value.hpp \
-	dep/toml11/toml/version.hpp \
-	dep/semver/semver.hpp	\
+	$(dep_json_include) \
+	$(dep_toml_include) \
+	$(dep_semver_include) \
+	$(dep_fmt_include) \
 	$(minori_qtheaders)
 
 minori_utf8proc_sources = \
@@ -266,10 +293,12 @@
 	$(minori_locale_qm)	\
 	$(minori_moc_sources)	\
 	$(minori_utf8proc_sources)	\
+	$(dep_fmt_source) \
 	rc/final_qrc.cc
 
 minori_includes = \
 	-I$(top_srcdir)/include \
+	-I$(top_srcdir)/dep/fmt/include \
 	-I$(top_srcdir)/dep/animone/include \
 	-I$(top_srcdir)/dep/pugixml/src \
 	-I$(top_srcdir)/dep/anitomy \