diff CMakeLists.txt @ 9:5c0397762b53

INCOMPLETE: megacommit :)
author Paper <mrpapersonic@gmail.com>
date Sun, 10 Sep 2023 03:59:16 -0400
parents 07a9095eaeed
children 4b198a111713
line wrap: on
line diff
--- a/CMakeLists.txt	Sat Aug 26 03:39:34 2023 -0400
+++ b/CMakeLists.txt	Sun Sep 10 03:59:16 2023 -0400
@@ -1,40 +1,56 @@
 cmake_minimum_required(VERSION 3.16)
 project(weeaboo LANGUAGES CXX OBJCXX)
 
+add_subdirectory(dep/anitomy)
+
 set(SRC_FILES
+	# Main entrypoint
 	src/main.cpp
-	src/config.cpp
-	src/filesystem.cpp
-	src/anilist.cpp
-	src/anime.cpp
-	src/json.cpp
-	src/date.cpp
-	src/time.cpp
-	src/sidebar.cpp
-	src/progress.cpp
-	src/pages/anime_list.cpp
-	src/pages/now_playing.cpp
-	src/pages/statistics.cpp
-	src/dialog/settings.cpp
-	src/dialog/information.cpp
-	src/dialog/settings/services.cpp
-	src/dialog/settings/application.cpp
-	src/ui_utils.cpp
-	src/string_utils.cpp
+
+	# Core files and datatype declarations...
+	src/core/anime.cpp
+	src/core/anime_db.cpp
+	src/core/config.cpp
+	src/core/date.cpp
+	src/core/filesystem.cpp
+	src/core/json.cpp
+	src/core/strings.cpp
+	src/core/time.cpp
+
+	# GUI stuff
+	src/gui/window.cpp
+	src/gui/sidebar.cpp
+	src/gui/ui_utils.cpp
+
+	# Dialogs
+	src/gui/dialog/information.cpp
+	src/gui/dialog/settings.cpp
+	src/gui/dialog/settings/application.cpp
+	src/gui/dialog/settings/services.cpp
+
+	# Main window pages
+	src/gui/pages/anime_list.cpp
+	src/gui/pages/now_playing.cpp
+	src/gui/pages/statistics.cpp
+
+	# Services (only AniList for now)
+	src/services/anilist.cpp
+
+	# Qt resources
 	rc/icons.qrc
 	dep/darkstyle/darkstyle.qrc
 )
 
-if(APPLE)
+if(APPLE) # Mac OS X (or OS X (or macOS))
 	list(APPEND SRC_FILES
 		src/sys/osx/dark_theme.mm
 		src/sys/osx/filesystem.mm
 	)
-elseif(WIN32)
+elseif(WIN32) # Windows
 	list(APPEND SRC_FILES src/sys/win32/dark_theme.cpp)
 endif()
 
-add_executable(weeaboo MACOSX_BUNDLE ${SRC_FILES})
+add_executable(weeaboo ${SRC_FILES})
 set_property(TARGET weeaboo PROPERTY CXX_STANDARD 20)
 set_property(TARGET weeaboo PROPERTY AUTOMOC ON)
 set_property(TARGET weeaboo PROPERTY AUTORCC ON)
@@ -45,6 +61,7 @@
 set(LIBRARIES
 	${Qt5Widgets_LIBRARIES}
 	${CURL_LIBRARIES}
+	anitomy
 )
 
 if(APPLE)
@@ -52,9 +69,11 @@
 	list(APPEND LIBRARIES ${COCOA_LIBRARY})
 endif()
 
-target_include_directories(weeaboo PUBLIC ${Qt5Widgets_INCLUDE_DIRS} ${CURL_INCLUDE_DIRS} PRIVATE src/include src/icons)
+target_include_directories(weeaboo PUBLIC ${Qt5Widgets_INCLUDE_DIRS} ${CURL_INCLUDE_DIRS} PRIVATE include)
 target_compile_options(weeaboo PRIVATE -Wall -Wextra -Wsuggest-override)
 if(APPLE)
 	target_compile_definitions(weeaboo PUBLIC MACOSX)
+elseif(WIN32)
+	target_compile_definitions(weeaboo PUBLIC WIN32)
 endif()
 target_link_libraries(weeaboo ${LIBRARIES})