diff dep/animia/CMakeLists.txt @ 189:649786bae914

*: etc. code cleanup I've removed most macros and stuff dep/animia: [UNTESTED] use raw C++ instead of Objective-C++
author Paper <mrpapersonic@gmail.com>
date Wed, 06 Dec 2023 19:42:33 -0500
parents c413e475f496
children 0fc126d52de4
line wrap: on
line diff
--- a/dep/animia/CMakeLists.txt	Wed Dec 06 13:44:36 2023 -0500
+++ b/dep/animia/CMakeLists.txt	Wed Dec 06 19:42:33 2023 -0500
@@ -30,28 +30,16 @@
 	# check anyway.
 	if (HAVE_COREFOUNDATION)
 		list(APPEND DEFINES HAVE_COREFOUNDATION)
+		list(APPEND SRC_FILES src/win/quartz.cc)
 
-		find_library(FOUNDATION_LIBRARY Foundation)
-		list(APPEND LIBRARIES ${FOUNDATION_LIBRARY})
+		find_library(FOUNDATION_LIBRARY Foundation) 
+		find_library(COREGRAPHICS_LIBRARY CoreGraphics)
+		find_library(APPKIT_LIBRARY AppKit)
+		list(APPEND LIBRARIES ${FOUNDATION_LIBRARY} ${COREGRAPHICS_LIBRARY} ${APPKIT_LIBRARY})
 	else()
 		message(STATUS "You don't have Core Foundation. How? What kind of voodoo magic did you do to cause this?")
 		message(WARNING "LaunchServices support will not be compiled.")
 	endif()
-
-	check_language(OBJCXX)
-	if(CMAKE_OBJCXX_COMPILER)
-		enable_language(OBJCXX)
-		list(APPEND SRC_FILES
-			src/win/quartz.mm
-		)
-
-		# we likely already have Foundation at this point.
-		find_library(COREGRAPHICS_LIBRARY CoreGraphics)
-		find_library(APPKIT_LIBRARY AppKit)
-		list(APPEND LIBRARIES ${COREGRAPHICS_LIBRARY} ${APPKIT_LIBRARY})
-	else() # NOT CMAKE_OBJCXX_COMPILER
-		message(WARNING "An Objective-C++ compiler couldn't be found! Window enumeration support will not be compiled.")
-	endif() # CMAKE_OBJCXX_COMPILER
 elseif(WIN32)
 	list(APPEND DEFINES WIN32)
 	list(APPEND SRC_FILES