diff dep/animone/Makefile.am @ 340:74e2365326c6

dep/animone: add experimental accessibility strategy I also moved most of the functions out of util/win32.cc, because that file is meant for things that are shared between the different functions, and currently that is only wide string conversion helpers.
author Paper <paper@paper.us.eu.org>
date Wed, 19 Jun 2024 23:13:55 -0400
parents f63dfa309380
children adb79bdde329
line wrap: on
line diff
--- a/dep/animone/Makefile.am	Wed Jun 19 14:02:11 2024 -0400
+++ b/dep/animone/Makefile.am	Wed Jun 19 23:13:55 2024 -0400
@@ -10,6 +10,7 @@
 	include/animone/types.h
 
 noinst_HEADERS = \
+	include/animone/a11y/win32.h \
 	include/animone/fd/freebsd.h \
 	include/animone/fd/openbsd.h \
 	include/animone/fd/netbsd.h \
@@ -20,13 +21,14 @@
 	include/animone/win/quartz.h \
 	include/animone/win/win32.h \
 	include/animone/win/x11.h \
+	include/animone/a11y.h \
 	include/animone/fd.h \
 	include/animone/strategies.h \
 	include/animone/util.h \
 	include/animone/win.h
 
 if BUILD_WIN
-files_win = src/fd/win32.cc src/win/win32.cc src/util/win32.cc
+files_win = src/a11y/win32.cc src/fd/win32.cc src/win/win32.cc src/util/win32.cc
 libs_win = -lole32 -luuid
 endif
 
@@ -65,6 +67,7 @@
 
 libanimone_la_SOURCES = \
 	src/animone.cc \
+	src/a11y.cc \
 	src/fd.cc \
 	src/player.cc \
 	src/strategist.cc \