diff Makefile.am @ 258:862d0d8619f6

*: HUUUGE changes animia has been renamed to animone, so instead of thinking of a health condition, you think of a beautiful flower :) I've also edited some of the code for animone, but I have no idea if it even works or not because I don't have a mac or windows machine lying around. whoops! ... anyway, all of the changes divergent from Anisthesia are now licensed under BSD. it's possible that I could even rewrite most of the code to where I don't even have to keep the MIT license, but that's thinking too far into the future I've been slacking off on implementing the anime seasons page, mostly out of laziness. I think I'd have to create another db file specifically for the seasons anyway, this code is being pushed *primarily* because the hard drive it's on is failing! yay :)
author Paper <paper@paper.us.eu.org>
date Mon, 01 Apr 2024 02:43:44 -0400
parents fe702c8f161f
children dd211ff68b36
line wrap: on
line diff
--- a/Makefile.am	Sun Feb 18 16:02:14 2024 -0500
+++ b/Makefile.am	Mon Apr 01 02:43:44 2024 -0400
@@ -20,7 +20,7 @@
 
 minori_qtrc = \
 	$(top_srcdir)/rc/icons/icons.qrc	\
-	$(top_srcdir)/rc/player_data.qrc
+	$(top_srcdir)/rc/animone.qrc
 
 # various things we want to distribute
 
@@ -55,20 +55,20 @@
 	$(top_srcdir)/rc/icons/favicon.png
 
 minori_linux_rc = \
-	$(top_srcdir)/rc/linux/Minori.desktop \
-	$(top_srcdir)/rc/linux/Minori.png
+	$(top_srcdir)/rc/sys/linux/Minori.desktop \
+	$(top_srcdir)/rc/sys/linux/Minori.png
 
 minori_osx_rc = \
-	$(top_srcdir)/rc/osx/Minori.app/Contents/Resources/Minori.icns \
-	$(top_srcdir)/rc/osx/Minori.app/Contents/Info.plist \
-	$(top_srcdir)/rc/osx/Minori.app/Contents/PkgInfo
+	$(top_srcdir)/rc/sys/osx/Minori.app/Contents/Resources/Minori.icns \
+	$(top_srcdir)/rc/sys/osx/Minori.app/Contents/Info.plist \
+	$(top_srcdir)/rc/sys/osx/Minori.app/Contents/PkgInfo
 
 minori_win32_rc = \
-	$(top_srcdir)/rc/win32/dark/dark.qrc \
-	$(top_srcdir)/rc/win32/dark/dark.qss \
-	$(top_srcdir)/rc/win32/favicon.ico \
-	$(top_srcdir)/rc/win32/resource.rc \
-	$(top_srcdir)/rc/win32/version.rc
+	$(top_srcdir)/rc/sys/win32/dark/dark.qrc \
+	$(top_srcdir)/rc/sys/win32/dark/dark.qss \
+	$(top_srcdir)/rc/sys/win32/favicon.ico \
+	$(top_srcdir)/rc/sys/win32/resource.rc \
+	$(top_srcdir)/rc/sys/win32/version.rc
 
 minori_scripts = \
 	$(top_srcdir)/scripts/osx/deploy_build.sh \
@@ -108,7 +108,7 @@
 WRCFLAGS = --use-temp-file -I. -I$(srcdir) $(wrcflags_version) $(CPPFLAGS)
 .rc.$(OBJEXT):
 	$(WINDRES) $(WRCFLAGS) -i $< -o $@
-files_windres=rc/win32/version.rc rc/win32/resource.rc
+files_windres=rc/sys/win32/version.rc rc/sys/win32/resource.rc
 
 endif # BUILD_WINDRES
 
@@ -147,7 +147,6 @@
 	include/gui/widgets/sidebar.h			\
 	include/gui/widgets/text.h		\
 	include/gui/widgets/elided_label.h	\
-	include/gui/layouts/flow_layout.h	\
 	include/gui/locale.h	\
 	include/gui/theme.h			\
 	include/gui/window.h
@@ -196,7 +195,6 @@
 	src/gui/dialog/about.cc		\
 	src/gui/dialog/information.cc		\
 	src/gui/dialog/settings.cc		\
-	src/gui/layouts/flow_layout.cc	\
 	src/gui/pages/anime_list.cc		\
 	src/gui/pages/history.cc		\
 	src/gui/pages/now_playing.cc		\
@@ -238,7 +236,7 @@
 
 minori_includes = \
 	-I$(top_srcdir)/include \
-	-I$(top_srcdir)/dep/animia/include \
+	-I$(top_srcdir)/dep/animone/include \
 	-I$(top_srcdir)/dep/pugixml/src \
 	-I$(top_srcdir)/dep/anitomy \
 	-I$(top_srcdir)/dep
@@ -247,21 +245,21 @@
 minori_CXXFLAGS = $(QT_CXXFLAGS) $(cflags_osx) $(cflags_glib) $(cflags_win)
 minori_LDFLAGS = $(QT_LDFLAGS) $(ldflags_osx) $(ldflags_win)
 
-minori_DEPENDENCIES = dep/pugixml/libpugixml.la dep/animia/libanimia.la dep/anitomy/libanitomy.la
+minori_DEPENDENCIES = dep/pugixml/libpugixml.la dep/animone/libanimone.la dep/anitomy/libanitomy.la
 minori_LDADD = $(minori_DEPENDENCIES) $(libs_glib) $(LIBCURL) $(QT_LIBS) $(libs_osx) $(libs_win)
 
 # Build only one qrc, otherwise we get a ton of
 # weird linking errors
 rc/final_qrc.cc: $(minori_qtrc)
-	$(RCC) -o $@ $(minori_qtrc)
+	$(QT_RCC) -o $@ $(minori_qtrc)
 
 .h_moc.cc:
 	$(MKDIR_P) -- $$(dirname $@)
-	$(MOC) -o $@ $(minori_includes) $<
+	$(QT_MOC) -o $@ $(minori_includes) $<
 
 .ts.qm:
 	$(MKDIR_P) $$(dirname $@); \
-	$(LRELEASE) $< -qm $@
+	$(QT_LRELEASE) $< -qm $@
 
 SUFFIXES = .h _moc.cc .ts .qm
 SUBDIRS = $(subdirs)