diff configure.ac @ 258:862d0d8619f6

*: HUUUGE changes animia has been renamed to animone, so instead of thinking of a health condition, you think of a beautiful flower :) I've also edited some of the code for animone, but I have no idea if it even works or not because I don't have a mac or windows machine lying around. whoops! ... anyway, all of the changes divergent from Anisthesia are now licensed under BSD. it's possible that I could even rewrite most of the code to where I don't even have to keep the MIT license, but that's thinking too far into the future I've been slacking off on implementing the anime seasons page, mostly out of laziness. I think I'd have to create another db file specifically for the seasons anyway, this code is being pushed *primarily* because the hard drive it's on is failing! yay :)
author Paper <paper@paper.us.eu.org>
date Mon, 01 Apr 2024 02:43:44 -0400
parents c130f47f6f48
children 9a04802848c0
line wrap: on
line diff
--- a/configure.ac	Sun Feb 18 16:02:14 2024 -0500
+++ b/configure.ac	Mon Apr 01 02:43:44 2024 -0400
@@ -2,7 +2,7 @@
 
 AC_CANONICAL_HOST
 
-AC_CONFIG_SUBDIRS([dep/pugixml dep/animia dep/anitomy])
+AC_CONFIG_SUBDIRS([dep/pugixml dep/animone dep/anitomy])
 AC_CONFIG_SRCDIR([src/main.cc])
 AC_CONFIG_AUX_DIR([build-aux])
 AC_CONFIG_MACRO_DIRS([m4])
@@ -19,9 +19,14 @@
 LT_INIT
 
 dnl Qt?
-AT_WITH_QT([widgets gui core], [], [], [have_qt=no], [have_qt=yes])
+have_qt=no
+AX_HAVE_QT
 
 AS_IF([test "x$have_qt" = "xno"], [AC_MSG_ERROR([*** Qt not found.])])
+AC_SUBST([QT_LRELEASE])
+AC_SUBST([QT_LUPDATE])
+AC_SUBST([QT_MOC])
+AC_SUBST([QT_RCC])
 
 dnl need this for moc
 AC_PROG_MKDIR_P