diff dep/animone/Makefile.am @ 258:862d0d8619f6

*: HUUUGE changes animia has been renamed to animone, so instead of thinking of a health condition, you think of a beautiful flower :) I've also edited some of the code for animone, but I have no idea if it even works or not because I don't have a mac or windows machine lying around. whoops! ... anyway, all of the changes divergent from Anisthesia are now licensed under BSD. it's possible that I could even rewrite most of the code to where I don't even have to keep the MIT license, but that's thinking too far into the future I've been slacking off on implementing the anime seasons page, mostly out of laziness. I think I'd have to create another db file specifically for the seasons anyway, this code is being pushed *primarily* because the hard drive it's on is failing! yay :)
author Paper <paper@paper.us.eu.org>
date Mon, 01 Apr 2024 02:43:44 -0400
parents
children 1a6a5d3a94cd
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dep/animone/Makefile.am	Mon Apr 01 02:43:44 2024 -0400
@@ -0,0 +1,83 @@
+lib_LTLIBRARIES = libanimone.la
+
+include_HEADERS = \
+	include/animone.h
+
+animiadir = $(includedir)/animone
+nobase_animia_HEADERS = \
+	include/animone/media.h \
+	include/animone/player.h \
+	include/animone/types.h
+
+noinst_HEADERS = \
+	include/animone/fd/kvm.h \
+	include/animone/fd/proc.h \
+	include/animone/fd/win32.h \
+	include/animone/fd/xnu.h \
+	include/animone/util/osx.h \
+	include/animone/util/win32.h \
+	include/animone/win/quartz.h \
+	include/animone/win/win32.h \
+	include/animone/win/x11.h \
+	include/animone/fd.h \
+	include/animone/strategies.h \
+	include/animone/util.h \
+	include/animone/win.h
+
+if BUILD_WIN
+files_win = src/fd/win32.cc src/win/win32.cc src/util/win32.cc
+libs_win = -lole32 -luuid
+endif
+
+if BUILD_OSX
+files_osx = src/fd/xnu.cc src/win/quartz.cc src/util/osx.cc
+libs_osx = -lobjc
+ldflags_osx = -framework Foundation -framework CoreGraphics -framework ApplicationServices
+endif
+
+if BUILD_LINUX
+files_linux = src/fd/proc.cc
+endif
+
+# these should be in standard locations anyway
+if BUILD_LIBUTIL
+libs_libutil = -lutil
+endif
+
+if BUILD_LIBKVM
+files_libkvm = src/fd/kvm.cc
+libs_libkvm = -lkvm
+endif
+
+if BUILD_XCB
+files_x11 = src/win/x11.cc
+cflags_x11 = $(XCB_CFLAGS)
+libs_x11 = $(XCB_LIBS)
+endif
+
+EXTRA_DIST = \
+	$(top_srcdir)/data/players.anisthesia
+
+libanimone_la_SOURCES = \
+	src/animone.cc \
+	src/fd.cc \
+	src/player.cc \
+	src/strategist.cc \
+	src/util.cc \
+	src/win.cc \
+	$(files_win) \
+	$(files_osx) \
+	$(files_linux) \
+	$(files_libutil) \
+	$(files_libkvm) \
+	$(files_x11) \
+	$(files_wayland)
+
+libanimone_la_CPPFLAGS = -I$(top_srcdir)/include $(DEFS)
+
+libanimone_la_CXXFLAGS = -std=c++17 $(cflags_osx) $(cflags_x11) $(cflags_wayland)
+libanimone_la_LDFLAGS = -version-info 0:0:0 $(ldflags_osx)
+
+libanimone_la_LIBADD = $(libs_win) $(libs_wayland) $(libs_x11) $(libs_osx) $(libs_libutil) $(libs_libkvm)
+
+ACLOCAL_AMFLAGS = -I m4