diff dep/animone/CMakeLists.txt @ 366:886f66775f31

animone: add preliminary AT-SPI stuff anime_list: finish the regular singular right click menu
author Paper <paper@tflc.us>
date Sun, 17 Nov 2024 19:56:01 -0500
parents 1faa72660932
children
line wrap: on
line diff
--- a/dep/animone/CMakeLists.txt	Wed Oct 02 23:06:43 2024 -0400
+++ b/dep/animone/CMakeLists.txt	Sun Nov 17 19:56:01 2024 -0500
@@ -87,6 +87,14 @@
 		list(APPEND INCLUDE_DIRS ${XCB_INCLUDE_DIRS})
 		list(APPEND SRC_FILES src/win/x11.cc)
 	endif() # XCB_FOUND
+
+	pkg_check_modules(ATSPI atspi-2)
+	if (ATSPI_FOUND)
+		list(APPEND DEFINES USE_ATSPI)
+		list(APPEND LIBRARIES ${ATSPI_LINK_LIBRARIES})
+		list(APPEND INCLUDE_DIRS ${ATSPI_INCLUDE_DIRS})
+		list(APPEND SRC_FILES src/a11y/atspi.cc)
+	endif() # ATSPI_FOUND
 endif() # PKG_CONFIG_FOUND
 
 add_library(animia SHARED ${SRC_FILES})