diff Makefile.am @ 264:9a04802848c0

*: improve multiple things e.g. making some strings.cc functions modify strings in-place, improving m4_ax_have_qt.m4 code, making anime_db.cc rely on std::optional rather than std::shared_ptr (which was stupid anyway)
author Paper <paper@paper.us.eu.org>
date Thu, 11 Apr 2024 10:15:57 -0400
parents 8e282d0dc282
children 09c5bd74fe93
line wrap: on
line diff
--- a/Makefile.am	Wed Apr 03 20:46:40 2024 -0400
+++ b/Makefile.am	Thu Apr 11 10:15:57 2024 -0400
@@ -178,6 +178,9 @@
 	dep/semver/semver.hpp	\
 	$(minori_qtheaders)
 
+minori_utf8proc_sources = \
+	dep/utf8proc/utf8proc.c
+
 minori_SOURCES = \
 	src/core/anime_db.cc		\
 	src/core/anime.cc		\
@@ -231,6 +234,7 @@
 	$(minori_qtrc)	\
 	$(minori_locale_qm)	\
 	$(minori_moc_sources)	\
+	$(minori_utf8proc_sources)	\
 	rc/locale/translations.qrc	\
 	rc/final_qrc.cc
 
@@ -241,6 +245,7 @@
 	-I$(top_srcdir)/dep/animone/include \
 	-I$(top_srcdir)/dep/pugixml/src \
 	-I$(top_srcdir)/dep/anitomy \
+	-I$(top_srcdir)/dep/utf8proc \
 	-I$(top_srcdir)/dep
 
 minori_CPPFLAGS = $(QT_CPPFLAGS) $(LIBCURL_CPPFLAGS) $(minori_includes)