diff CMakeLists.txt @ 179:9c4645100fec

osx: clean up includes, we do not need cocoa what we *do* need is the very basics that animia already depends on anyway. these are basically guaranteed to be on any macos system, making it fairly portable now... I haven't tested this :) I don't have a macos machine right now...
author Paper <mrpapersonic@gmail.com>
date Mon, 04 Dec 2023 12:03:36 -0500
parents 6fdf0632c003
children 649786bae914
line wrap: on
line diff
--- a/CMakeLists.txt	Mon Dec 04 11:51:30 2023 -0500
+++ b/CMakeLists.txt	Mon Dec 04 12:03:36 2023 -0500
@@ -43,8 +43,9 @@
 
 # We need Cocoa for some OS X stuff
 if(APPLE)
-	find_library(COCOA_LIBRARY Cocoa)
-	list(APPEND LIBRARIES ${COCOA_LIBRARY})
+	find_library(FOUNDATION_LIBRARY Foundation)
+	find_library(APPKIT_LIBRARY AppKit)
+	list(APPEND LIBRARIES ${FOUNDATION_LIBRARY} ${APPKIT_LIBRARY})
 endif()
 
 set(SRC_FILES