diff dep/anitomy/CMakeLists.txt @ 347:a0aa8c8c4307

dep/anitomy: port to use UCS-4 rather than wide strings rationale: wide strings are not the same on every platform, and might not even be Unicode. (while they usually are, its possible that they are not) I was *going* to change StringToInt to use a string stream, but outputting to an integer doesn't seem to work at all with UCS-4, even though it ought to, so I just rolled my own that uses the arabic digits only.
author Paper <paper@paper.us.eu.org>
date Sun, 23 Jun 2024 10:32:09 -0400
parents 1faa72660932
children
line wrap: on
line diff
--- a/dep/anitomy/CMakeLists.txt	Thu Jun 20 07:40:47 2024 -0400
+++ b/dep/anitomy/CMakeLists.txt	Sun Jun 23 10:32:09 2024 -0400
@@ -13,4 +13,4 @@
 )
 set_target_properties(anitomy PROPERTIES
     PUBLIC_HEADER anitomy/anitomy.h CXX_STANDARD 17)
-target_include_directories(anitomy PRIVATE src)
+target_include_directories(anitomy PRIVATE src dep/srell)