diff CMakeLists.txt @ 114:ab191e28e69d

*: add initial torrent stuff WOAH! these checkboxes are a pain in my fucking ass
author Paper <mrpapersonic@gmail.com>
date Tue, 07 Nov 2023 08:03:42 -0500
parents 80f49f623d30
children 254b1d2b7096
line wrap: on
line diff
--- a/CMakeLists.txt	Mon Nov 06 13:48:11 2023 -0500
+++ b/CMakeLists.txt	Tue Nov 07 08:03:42 2023 -0500
@@ -12,14 +12,7 @@
 option(BUILD_SHARED_LIBS "Build using shared libraries" ON)
 option(USE_QT6 "Force build with Qt 6" OFF)
 option(USE_QT5 "Force build with Qt 5" OFF)
-# The reason I'm not specifying this an an option() is that
-# that will *save the value*, which causes the *.qm translation
-# files to not automatically be generated, screwing up the whole
-# "automation" part of it.
-#
-# Ugh.
-#
-# option(UPDATE_TRANSLATIONS "Update *.ts translation files" OFF)
+option(UPDATE_TRANSLATIONS "Update *.ts translation files" OFF)
 
 add_subdirectory(dep/anitomy)
 add_subdirectory(dep/animia)
@@ -45,6 +38,7 @@
 	${Qt${QT_VERSION_MAJOR}Widgets_LIBRARIES}
 	anitomy
 	animia
+	pugixml
 )
 
 # We need Cocoa for some OS X stuff