diff configure.ac @ 342:adb79bdde329

dep/animone: fix tons of issues for example, the window ID stuff was just... completely wrong. since we're supporting multiple different window systems, it *has* to be a union rather than just a single integer type. HWND is also not a DWORD, it's a pointer(!), so now it's stored as a std::uintptr_t. (this probably breaks things)
author Paper <paper@paper.us.eu.org>
date Thu, 20 Jun 2024 03:03:05 -0400
parents 703fb7d7c917
children
line wrap: on
line diff
--- a/configure.ac	Wed Jun 19 23:21:19 2024 -0400
+++ b/configure.ac	Thu Jun 20 03:03:05 2024 -0400
@@ -100,6 +100,8 @@
 	dnl Check for windres
 	AC_CHECK_TOOL([WINDRES], [windres])
 	AC_SUBST([WINDRES])
+
+	AC_DEFINE([ANIMONE_STATIC], [1], [stupid windows thing])
 elif test "x$build_osx" = "xyes"; then
 	AC_DEFINE([MACOSX])
 else