diff dep/animone/Makefile.am @ 342:adb79bdde329

dep/animone: fix tons of issues for example, the window ID stuff was just... completely wrong. since we're supporting multiple different window systems, it *has* to be a union rather than just a single integer type. HWND is also not a DWORD, it's a pointer(!), so now it's stored as a std::uintptr_t. (this probably breaks things)
author Paper <paper@paper.us.eu.org>
date Thu, 20 Jun 2024 03:03:05 -0400
parents 74e2365326c6
children
line wrap: on
line diff
--- a/dep/animone/Makefile.am	Wed Jun 19 23:21:19 2024 -0400
+++ b/dep/animone/Makefile.am	Thu Jun 20 03:03:05 2024 -0400
@@ -29,7 +29,7 @@
 
 if BUILD_WIN
 files_win = src/a11y/win32.cc src/fd/win32.cc src/win/win32.cc src/util/win32.cc
-libs_win = -lole32 -luuid
+libs_win = -lole32 -loleaut32 -luuid
 endif
 
 if BUILD_OSX
@@ -83,8 +83,8 @@
 libanimone_la_CPPFLAGS = -I$(top_srcdir)/include $(DEFS)
 
 libanimone_la_CXXFLAGS = -std=c++17 $(cflags_osx) $(cflags_x11) $(cflags_wayland)
-libanimone_la_LDFLAGS = -version-info 0:0:0 $(ldflags_osx)
+libanimone_la_LDFLAGS = -no-undefined -version-info 0:0:0 $(ldflags_osx)
 
-libanimone_la_LIBADD = $(libs_win) $(libs_wayland) $(libs_x11) $(libs_osx) $(libs_libutil) $(libs_libkvm)
+libanimone_la_LIBADD = $(libs_win) $(libs_wayland) $(libs_x11) $(libs_osx) $(libs_freebsd) $(libs_openbsd)
 
 ACLOCAL_AMFLAGS = -I m4