diff CMakeLists.txt @ 102:b315f3759c56

*: big patch 1. use a wrapper for mINI that enables case sensitivity (personal preference) 2. rename dark_theme.cc to theme.cc and change it to be a class 3. include the "dep" folder so we don't have stupidity in json.h or ini.h 4. I think the graph was also tweaked a lot in this, nothing is constexpr and size is found at runtime...
author Paper <mrpapersonic@gmail.com>
date Fri, 03 Nov 2023 21:32:52 -0400
parents c537996cf67b
children 621084cc542c
line wrap: on
line diff
--- a/CMakeLists.txt	Fri Nov 03 14:06:02 2023 -0400
+++ b/CMakeLists.txt	Fri Nov 03 21:32:52 2023 -0400
@@ -63,7 +63,7 @@
 
 	# Main window
 	src/gui/window.cc
-	src/gui/dark_theme.cc
+	src/gui/theme.cc
 
 	# Main window pages
 	src/gui/pages/anime_list.cc
@@ -122,7 +122,7 @@
 set_property(TARGET minori PROPERTY AUTOMOC ON)
 set_property(TARGET minori PROPERTY AUTORCC ON)
 
-target_include_directories(minori PUBLIC ${CURL_INCLUDE_DIRS} PRIVATE include dep/pugixml/src dep/animia/include dep/anitomy dep/mini)
+target_include_directories(minori PUBLIC ${CURL_INCLUDE_DIRS} PRIVATE include dep/pugixml/src dep/animia/include dep/anitomy dep)
 if(USE_QT6)
 	target_include_directories(minori PUBLIC ${Qt6Widgets_INCLUDE_DIRS})
 else()