diff CMakeLists.txt @ 345:d085c05247bd

build: fix windows build
author Paper <paper@paper.us.eu.org>
date Thu, 20 Jun 2024 07:39:01 -0400
parents 1faa72660932
children e65b89bcc528
line wrap: on
line diff
--- a/CMakeLists.txt	Thu Jun 20 06:00:28 2024 -0400
+++ b/CMakeLists.txt	Thu Jun 20 07:39:01 2024 -0400
@@ -31,7 +31,9 @@
 
 find_package(Qt${QT_VERSION_MAJOR} REQUIRED COMPONENTS Widgets LinguistTools)
 
-find_package(CURL REQUIRED)
+# find_package(CURL) fails sometimes
+find_package(PkgConfig REQUIRED)
+pkg_check_modules(CURL REQUIRED curl)
 
 set(LIBRARIES
 	${CURL_LIBRARIES}