diff CMakeLists.txt @ 46:d0adc4aedfc8

*: update... this commit: 1. consolidates dark theme stuff to dark_theme.cpp 2. creates a new widgets folder to store all of our custom widgets 3. creates the list settings page in the information dialog, although much of it is nonfunctional: it doesn't save, and the status doesn't even get filled in... we'll fix this later!
author Paper <mrpapersonic@gmail.com>
date Sat, 23 Sep 2023 01:02:15 -0400
parents db445ce42057
children d8eb763e6661
line wrap: on
line diff
--- a/CMakeLists.txt	Fri Sep 22 15:21:55 2023 -0400
+++ b/CMakeLists.txt	Sat Sep 23 01:02:15 2023 -0400
@@ -39,10 +39,18 @@
 	src/core/strings.cpp
 	src/core/time.cpp
 
-	# GUI stuff
+	# Main window
 	src/gui/window.cpp
-	src/gui/sidebar.cpp
-	src/gui/ui_utils.cpp
+	src/gui/dark_theme.cpp
+
+	# Main window pages
+	src/gui/pages/anime_list.cpp
+	src/gui/pages/now_playing.cpp
+	src/gui/pages/statistics.cpp
+
+	# Custom widgets
+	src/gui/widgets/sidebar.cpp
+	src/gui/widgets/text.cpp
 
 	# Dialogs
 	src/gui/dialog/information.cpp
@@ -50,11 +58,6 @@
 	src/gui/dialog/settings/application.cpp
 	src/gui/dialog/settings/services.cpp
 
-	# Main window pages
-	src/gui/pages/anime_list.cpp
-	src/gui/pages/now_playing.cpp
-	src/gui/pages/statistics.cpp
-
 	# Translate
 	src/gui/translate/anime.cpp
 	src/gui/translate/anilist.cpp