diff CMakeLists.txt @ 55:d10b6c6b432e

add xml lib, we will need to use it eventually
author Paper <mrpapersonic@gmail.com>
date Tue, 26 Sep 2023 12:37:08 -0400
parents 466ac9870df9
children 3c802806b74a
line wrap: on
line diff
--- a/CMakeLists.txt	Tue Sep 26 11:18:50 2023 -0400
+++ b/CMakeLists.txt	Tue Sep 26 12:37:08 2023 -0400
@@ -8,6 +8,7 @@
 endif()
 
 add_subdirectory(dep/anitomy)
+add_subdirectory(dep/pugixml)
 
 # Fix for mingw64
 list(APPEND CMAKE_FIND_LIBRARY_SUFFIXES ".dll.a" ".a")
@@ -95,7 +96,7 @@
 set_property(TARGET minori PROPERTY AUTOMOC ON)
 set_property(TARGET minori PROPERTY AUTORCC ON)
 
-target_include_directories(minori PUBLIC ${Qt5Widgets_INCLUDE_DIRS} ${CURL_INCLUDE_DIRS} PRIVATE include)
+target_include_directories(minori PUBLIC ${Qt5Widgets_INCLUDE_DIRS} ${CURL_INCLUDE_DIRS} PRIVATE include dep/pugixml/src)
 target_compile_options(minori PRIVATE -Wall -Wextra -Wsuggest-override)
 if(APPLE)
 	target_compile_definitions(minori PUBLIC MACOSX)