diff CMakeLists.txt @ 75:d3e9310598b1

*: refactor some stuff text: "TextParagraph"s are now called sections, because that's the actual word for it :P text: new classes: Line and OneLineSection, solves many problems with paragraphs that are only one line long (ex. going out of bounds) http: reworked http stuff to allow threaded get requests, also moved it to its own file to (hopefully) remove clutter eventually I'll make a threaded post request method and use that in the "basic" function
author Paper <mrpapersonic@gmail.com>
date Wed, 04 Oct 2023 01:42:30 -0400
parents 442065432549
children 9b2b41f83a5e
line wrap: on
line diff
--- a/CMakeLists.txt	Tue Oct 03 06:12:43 2023 -0400
+++ b/CMakeLists.txt	Wed Oct 04 01:42:30 2023 -0400
@@ -56,6 +56,7 @@
 	src/core/config.cpp
 	src/core/date.cpp
 	src/core/filesystem.cpp
+	src/core/http.cpp
 	src/core/json.cpp
 	src/core/strings.cpp
 	src/core/time.cpp