diff CMakeLists.txt @ 47:d8eb763e6661

information.cpp: add widgets to the list tab, and add an "optional date" widget like taiga has so users can specify whether to set the date or not
author Paper <mrpapersonic@gmail.com>
date Mon, 25 Sep 2023 00:43:38 -0400
parents d0adc4aedfc8
children 75c804f713b2
line wrap: on
line diff
--- a/CMakeLists.txt	Sat Sep 23 01:02:15 2023 -0400
+++ b/CMakeLists.txt	Mon Sep 25 00:43:38 2023 -0400
@@ -1,6 +1,8 @@
 cmake_minimum_required(VERSION 3.16)
 project(minori LANGUAGES CXX)
 
+# this should check for the target system, rather than
+# the host system, for cross-compiling purposes
 if(APPLE)
 	enable_language(OBJCXX)
 endif()
@@ -51,6 +53,7 @@
 	# Custom widgets
 	src/gui/widgets/sidebar.cpp
 	src/gui/widgets/text.cpp
+	src/gui/widgets/optional_date.cpp
 
 	# Dialogs
 	src/gui/dialog/information.cpp
@@ -80,8 +83,9 @@
 	list(APPEND SRC_FILES src/sys/win32/dark_theme.cpp)
 endif()
 
-add_executable(minori ${SRC_FILES})
-set_property(TARGET minori PROPERTY CXX_STANDARD 20)
+add_executable(minori WIN32 ${SRC_FILES})
+# There's a bug in JFMC++ that keeps me from setting this to C++11.
+set_property(TARGET minori PROPERTY CXX_STANDARD 17)
 set_property(TARGET minori PROPERTY AUTOMOC ON)
 set_property(TARGET minori PROPERTY AUTORCC ON)