diff CMakeLists.txt @ 11:fc1bf97c528b

*: use C++11 standard I've been meaning to do this for a while, but I didn't want to reimplement the filesystem code. Now we are on C++11 and most compilers from the past 5 centuries should support this now
author Paper <mrpapersonic@gmail.com>
date Sun, 17 Sep 2023 06:14:30 -0400
parents 4b198a111713
children cf6a73a5ba1c
line wrap: on
line diff
--- a/CMakeLists.txt	Sat Sep 16 02:06:01 2023 -0400
+++ b/CMakeLists.txt	Sun Sep 17 06:14:30 2023 -0400
@@ -1,5 +1,5 @@
 cmake_minimum_required(VERSION 3.16)
-project(weeaboo LANGUAGES CXX OBJCXX)
+project(minori LANGUAGES CXX OBJCXX)
 
 add_subdirectory(dep/anitomy)
 
@@ -54,10 +54,10 @@
 	list(APPEND SRC_FILES src/sys/win32/dark_theme.cpp)
 endif()
 
-add_executable(weeaboo ${SRC_FILES})
-set_property(TARGET weeaboo PROPERTY CXX_STANDARD 20)
-set_property(TARGET weeaboo PROPERTY AUTOMOC ON)
-set_property(TARGET weeaboo PROPERTY AUTORCC ON)
+add_executable(minori ${SRC_FILES})
+set_property(TARGET minori PROPERTY CXX_STANDARD 11)
+set_property(TARGET minori PROPERTY AUTOMOC ON)
+set_property(TARGET minori PROPERTY AUTORCC ON)
 
 find_package(Qt5 COMPONENTS Widgets Test REQUIRED)
 find_package(CURL REQUIRED)
@@ -74,11 +74,11 @@
 	list(APPEND LIBRARIES ${COCOA_LIBRARY})
 endif()
 
-target_include_directories(weeaboo PUBLIC ${Qt5Widgets_INCLUDE_DIRS} ${Qt5Test_INCLUDE_DIRS} ${CURL_INCLUDE_DIRS} PRIVATE include)
-target_compile_options(weeaboo PRIVATE -Wall -Wextra -Wsuggest-override)
+target_include_directories(minori PUBLIC ${Qt5Widgets_INCLUDE_DIRS} ${Qt5Test_INCLUDE_DIRS} ${CURL_INCLUDE_DIRS} PRIVATE include)
+target_compile_options(minori PRIVATE -Wall -Wextra -Wsuggest-override)
 if(APPLE)
-	target_compile_definitions(weeaboo PUBLIC MACOSX)
+	target_compile_definitions(minori PUBLIC MACOSX)
 elseif(WIN32)
-	target_compile_definitions(weeaboo PUBLIC WIN32)
+	target_compile_definitions(minori PUBLIC WIN32)
 endif()
-target_link_libraries(weeaboo ${LIBRARIES})
+target_link_libraries(minori ${LIBRARIES})