diff CMakeLists.txt @ 25:92156fe32755

impl/ppc/altivec: update to new implementation the signed average function is wrong; it needs to round up the number when only one of them is odd, but that doesn't necessarily seem to be true because altivec is weird, and that's what we need to emulate the quirks for. ugh. also the altivec backend uses the generic functions instead of fallbacks because it does indeed use the exact same memory structure as the generic implementation...
author Paper <paper@tflc.us>
date Sun, 24 Nov 2024 11:15:59 +0000
parents e26874655738
children d00b95f95dd1
line wrap: on
line diff
--- a/CMakeLists.txt	Sun Nov 24 03:32:53 2024 -0500
+++ b/CMakeLists.txt	Sun Nov 24 11:15:59 2024 +0000
@@ -1,6 +1,6 @@
 cmake_minimum_required(VERSION 3.23)
 
-project(vec VERSION 3.0.0 DESCRIPTION "a tiny C99 SIMD vector library")
+project(vec VERSION 3.0.0 DESCRIPTION "a tiny C99 SIMD vector library" LANGUAGES C)
 
 add_library(vec SHARED "src/vec.c;src/cpu.c;src/impl/generic.c;src/impl/fallback.c")
 
@@ -33,10 +33,10 @@
 	endif()
 	# TODO we have to try_compile to detect NEON
 else()
-	#check_c_compiler_flag("-maltivec" COMPILER_HAS_ALTIVEC)
-	#if(COMPILER_HAS_ALTIVEC)
-	#	set(COMPILER_ALTIVEC_FLAGS "-maltivec")
-	#endif()
+	check_c_compiler_flag("-maltivec" COMPILER_HAS_ALTIVEC)
+	if(COMPILER_HAS_ALTIVEC)
+		set(COMPILER_ALTIVEC_FLAGS "-maltivec")
+	endif()
 	#check_c_compiler_flag("-mfpu=neon" COMPILER_HAS_NEON)
 	#if(COMPILER_HAS_NEON)
 	#	set(COMPILER_NEON_FLAGS "-mfpu=neon")