diff test/CMakeLists.txt @ 23:e26874655738

*: huge refactor, new major release (hahaha) I keep finding things that are broken... The problem NOW was that vec would unintentionally build some functions with extended instruction sets, which is Bad and would mean that for all intents and purposes the CPU detection was completely broken. Now vec is no longer header only either. Boohoo. However this gives a lot more flexibility to vec since we no longer want or need to care about C++ crap. The NEON and Altivec implementations have not been updated which means they won't compile hence why they're commented out in the cmake build file.
author Paper <paper@tflc.us>
date Sun, 24 Nov 2024 02:52:40 -0500
parents
children 92156fe32755
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/test/CMakeLists.txt	Sun Nov 24 02:52:40 2024 -0500
@@ -0,0 +1,10 @@
+cmake_minimum_required(VERSION 3.23)
+
+project(vec-tests)
+
+# add main vec directory
+add_subdirectory(.. vec)
+
+add_executable(vec-tests test.c)
+
+target_link_libraries(vec-tests vec)