diff dep/animone/configure.ac @ 342:adb79bdde329

dep/animone: fix tons of issues for example, the window ID stuff was just... completely wrong. since we're supporting multiple different window systems, it *has* to be a union rather than just a single integer type. HWND is also not a DWORD, it's a pointer(!), so now it's stored as a std::uintptr_t. (this probably breaks things)
author Paper <paper@paper.us.eu.org>
date Thu, 20 Jun 2024 03:03:05 -0400
parents f63dfa309380
children
line wrap: on
line diff
--- a/dep/animone/configure.ac	Wed Jun 19 23:21:19 2024 -0400
+++ b/dep/animone/configure.ac	Thu Jun 20 03:03:05 2024 -0400
@@ -1,4 +1,4 @@
-AC_INIT([animone], [2.0.0])
+AC_INIT([animone], [0.2.0])
 
 AC_CANONICAL_HOST
 
@@ -12,7 +12,7 @@
 AC_PROG_CXX
 
 AM_PROG_AR
-LT_INIT
+LT_INIT([win32-dll])
 
 build_win32=no
 build_osx=no
@@ -70,7 +70,6 @@
 AM_CONDITIONAL([BUILD_LINUX], [test "x$build_linux" = "xyes"])
 AM_CONDITIONAL([BUILD_FREEBSD], [test "x$build_libutil" = "xyes"])
 AM_CONDITIONAL([BUILD_OPENBSD], [test "x$build_kvm" = "xyes"])
-AM_CONDITIONAL([BUILD_BSD], [test "x$build_bsd" = "xyes"])
 
 AM_CONDITIONAL([BUILD_XCB], [test "x$build_x11" = "xyes"])